Awful buzz/hum from Samson B3 Studio speakers

Discussion in 'Recording Studio' started by sazista, Jul 5, 2016.

  1. sazista

    sazista Active Member

    Joined:
    Dec 9, 2015
    Messages:
    580
    Likes Received:
    237
    I have used them before but never experienced this problem that really rains on my parade. I use a Focusrite 2i4, Garageband and a Fender Mustang III V2 amp, and of course my SG!
    I monitor through headphones but when setting it up to the monitors the hum is loud and of course increases with the volume. It is not useable. I did not find any difference with Amplitude or GB amp presets. The hum comes on as soon as the speakers turn on.
    The only thing that i can think of is that this is now set up in a new house. Could the poor electrics be the cause? Ideas? Thanks folks.
     
  2. donepearce

    donepearce Well-Known Member

    Joined:
    Dec 12, 2012
    Messages:
    4,663
    Likes Received:
    4,018
    Location:
    London, new hearing aid project - exciting
    Sounds like a ground loop. Do the speakers still buzz when you unplug the signal from them?
     
  3. sazista

    sazista Active Member

    Joined:
    Dec 9, 2015
    Messages:
    580
    Likes Received:
    237
    I will check soon. Thanks
     
  4. sazista

    sazista Active Member

    Joined:
    Dec 9, 2015
    Messages:
    580
    Likes Received:
    237
    By process of elimination i got rid of it. It only did it when i plugged the RCA adaptor i to the headphone jack of my macbook. I switched the configuration of output audio in Logic and the Mac. It eventually shut up. Who knows?
     

Share This Page